Page 1 of 1

Task fails with socket error #0 (error #10) & stops runn

PostPosted: Fri Mar 14, 2008 5:25 pm
by ethanwilde
We have TurboFTP version 5.60 Build 6.32 - WinSock 2.0 running on a Windows 2003 Server. We have set up a single sync task using SFTP protocol. It ran fine for about 2 days, and then failed, never to run again.

The task log reports a successful login and then a socket error #0 (error #10) as the last two events logged about a week ago.

The scheduler log reports that the task started, but doesn't have an "ended successfully" entry after the last start that encountered the socket error.

The task has never run again, although we can perform successful manual connections and syncs via the TurboFTP GUI client.

Help!

PostPosted: Sat Mar 15, 2008 2:56 am
by Saturn
Hi,
Can you forward the log?Thanks.

Hope

How do I forward a log file?

PostPosted: Thu Mar 20, 2008 6:24 pm
by ethanwilde
Is there an email address you want me to send the log file? Or is there some other method I should use?

PostPosted: Tue Mar 25, 2008 7:32 am
by ethanwilde
Task log:


Code: Select all
[2008/03/08 01:04:32] COMMAND-0:>   Sent client version string 'SSH-2.0-TurboFTP_SSHM_1.00'
[2008/03/08 01:04:32] STATUS-0:>   Crypto negotiation done, Server to client cipher:aes128-cbc, mac:hmac-sha1, compression:none.
[2008/03/08 01:04:32] STATUS-0:>   Crypto negotiation done, Client to server cipher:aes128-cbc, mac:hmac-sha1, compression:none.
[2008/03/08 01:04:33] STATUS-0:>   Fingerprint of the host public key found in cache.
[2008/03/08 01:04:33] STATUS-0:>   Authenticating with method 'password'
[2008/03/08 01:04:33] STATUS-0:>   Login successful.
[2008/03/08 01:04:33] ERROR-0:>   socket error #0 (error #10)


Sync Service log:

Code: Select all
[2008/03/08 Sat 01:02:32] Task 1 (Sync: M:\Websites\Sitebots\root\www\dynamic and americanart.si.edu/data/www/dynamic) started.

[2008/03/08 Sat 01:02:36] Task 1 (Sync: M:\Websites\Sitebots\root\www\dynamic and americanart.si.edu/data/www/dynamic) ended successfully.

[2008/03/08 Sat 01:04:32] Task 1 (Sync: M:\Websites\Sitebots\root\www\dynamic and americanart.si.edu/data/www/dynamic) started.


There are no further log entries after these lines in EITHER log.

Please help!

PostPosted: Fri Mar 28, 2008 4:16 pm
by admin
Hi,

Please don't omit the server version string in the log file.

Leon

Task Log including server string

PostPosted: Tue Apr 01, 2008 6:21 am
by ethanwilde
Here is a more complete snippet from the Sync Service log, with hostname of remote machine obfuscated for security purposes.

Code: Select all
[2008/03/08 01:04:32] ------------------------------------------------------------
[2008/03/08 01:04:32] STATUS-0:>   Start running task 1: Sync: M:\root\www\dynamic and HOSTNAME/data/www/dynamic.
[2008/03/08 01:04:32] STATUS-0:>   Task Settings: Scheme:0|Direct:0|IncFilter:|ExclFilter:|Netshare:0|IncSubdir|Repeat:2:0
[2008/03/08 01:04:32] STATUS-0:>   Connecting to HOSTNAME Port 22 (try #1) ...
[2008/03/08 01:04:32]    Server version: SSH-2.0-OpenSSH_4.2
[2008/03/08 01:04:32]
[2008/03/08 01:04:32] COMMAND-0:>   Sent client version string 'SSH-2.0-TurboFTP_SSHM_1.00'
[2008/03/08 01:04:32] STATUS-0:>   Crypto negotiation done, Server to client cipher:aes128-cbc, mac:hmac-sha1, compression:none.
[2008/03/08 01:04:32] STATUS-0:>   Crypto negotiation done, Client to server cipher:aes128-cbc, mac:hmac-sha1, compression:none.
[2008/03/08 01:04:33] STATUS-0:>   Fingerprint of the host public key found in cache.
[2008/03/08 01:04:33] STATUS-0:>   Authenticating with method 'password'
[2008/03/08 01:04:33] STATUS-0:>   Login successful.
[2008/03/08 01:04:33] ERROR-0:>   socket error #0 (error #10)

PostPosted: Mon Apr 14, 2008 1:37 am
by admin
Hi,

Do you have the same problem when manually connect to the ssh server?

Leon

Re:

PostPosted: Thu Sep 03, 2009 7:44 am
by juanheredia
I'm having the same problem even in a manual connection. Could you help me please?
Thanks in advance.

COMMAND:> Sent client version string 'SSH-2.0-TurboFTP_SSHM_1.50'
STATUS:> Crypto negotiation done, Server to client cipher:aes128-cbc, mac:hmac-sha1, compression:none.
STATUS:> Crypto negotiation done, Client to server cipher:aes128-cbc, mac:hmac-sha1, compression:none.
STATUS:> Authenticating with method 'publickey'
STATUS:> Login successful.
ERROR:> socket error #0 (error #10)
STATUS:> Wait 10 seconds and try again...

Re: Task fails with socket error #0 (error #10) & stops runn

PostPosted: Fri Sep 04, 2009 1:56 am
by admin
What is the server string before 'Sent client version string 'SSH-2.0-TurboFTP_SSHM_1.50'?

Re: Task fails with socket error #0 (error #10) & stops runn

PostPosted: Fri Sep 04, 2009 7:07 am
by juanheredia
This is the complete log:

STATUS:> Connecting to sftp.caixagalicia.es Port 22 (try #2) ...
Server version: SSH-2.0-XFB.Gateway Windows
COMMAND:> Sent client version string 'SSH-2.0-TurboFTP_SSHM_1.50'
STATUS:> Crypto negotiation done, Server to client cipher:aes128-cbc, mac:hmac-sha1, compression:none.
STATUS:> Crypto negotiation done, Client to server cipher:aes128-cbc, mac:hmac-sha1, compression:none.
STATUS:> Authenticating with method 'publickey'
STATUS:> Login successful.
ERROR:> socket error #0 (error #10)
STATUS:> Wait 10 seconds and try again...

Re: Task fails with socket error #0 (error #10) & stops runn

PostPosted: Fri Sep 04, 2009 8:45 am
by admin
Is it possible to set up a test account on that server for us to test? If yes please send the test account credentials to support@tbsoftinc.com.