Page 1 of 1

Email not sent on error

PostPosted: Mon Mar 17, 2008 4:43 pm
by MSV
We had FTP errors that were not reported by the email notifier. Subsequent test emails work - we had an error email at the same time as the first test after the problem was discovered.

I have posted a subset of the logs below

cheers, Paul

TurboFTP 5.30.582
Windows Server 2003

-----Task Log-----
[2008/03/14 22:30:00] ------------------------------------------------------------
[2008/03/14 22:30:00] STATUS-1:> Start running task 7: Safenames - Motorsport Vision.
[2008/03/14 22:30:00] STATUS-1:> Task Settings: Scheme:3|Direct:1|IncFilter:|ExclFilter:|Netshare:0|IncSubdir|IgnoreCase|Repeat:1:2
[2008/03/14 22:30:00] STATUS-1:> Connecting to 217.19.248.41 Port 21 (try #1) ...
[2008/03/14 22:30:00] STATUS-1:> Socket connected (IP = 217.19.248.41), waiting for server response ...
[2008/03/14 22:30:15] ERROR-1:> Connection timed out.
[2008/03/14 22:30:15] STATUS-1:> Connecting to 217.19.248.41 Port 21 (try #2) ...
[2008/03/14 22:30:15] STATUS-1:> Socket connected (IP = 217.19.248.41), waiting for server response ...
[2008/03/14 22:30:30] ERROR-1:> Connection timed out.
........
[2008/03/14 22:40:15] STATUS-1:> Exceeded retry limit, give up.
[2008/03/14 22:40:15] STATUS-1:> FTP thread #1 (SystemID 89972) terminated gracefully.

----Schedule Log----

[2008/03/14 Fri 22:30:00] Task 7 (Safenames - Motorsport Vision) started.
[2008/03/14 Fri 22:30:15] Task 6 (Safenames - Justinwilson) ended with errors.
[2008/03/14 Fri 22:40:00] Task 8 (Safenames - TCars) started.
[2008/03/14 Fri 22:40:15] Task 7 (Safenames - Motorsport Vision) ended with errors.

PostPosted: Mon Mar 24, 2008 3:33 am
by Saturn
Are you sure the option 'Enable E-mail notification' is checked?And you can check the option 'Log details of E-mail sending' to view the details.Please send the log if it still has this problem.Thanks.

PostPosted: Tue May 13, 2008 3:43 pm
by MSV
Sorry about the delay getting back.
I could not set the "log details" option because the version we use did not have it. Have upgraded to 5.60.642 and ticked the option. Will see how it goes.

PostPosted: Thu May 22, 2008 11:19 am
by MSV
We have the latest version loaded and every thing seems to be working, except the log files are not updated at all and there is no Turboftp.log file.
The scheduler shows the last run time of 13 May 2008.
The log files are all dated 13 May 2008, which is the date of the upgrade.

PostPosted: Wed Jun 04, 2008 3:19 am
by admin
Hi,

Please check [Options | Program data path]. The log files are generated in this folder and the path should exist on your machine.

Leon

PostPosted: Wed Jun 04, 2008 9:52 am
by MSV
Leon,
You were right, there is now a separate path for schedule related data - this seems to be a change from previous versions. Unfortunately this seems to be driven from the registry in HKCU, which defeats the "run as a service" mode - which should be userless.

It also now seems to have 2 copies of the ini file and the schedule.dat. Which ones should we be backing up / restoring for DR purposes?

cheers, Paul

PostPosted: Wed Jun 04, 2008 4:51 pm
by admin
Hi,

To have Sync Service running and log without a problem please ensure
the program data path is the application data path for all users.

The address book file and schedule data etc stored in program data path are the files you should back up.

Leon

PostPosted: Fri Sep 26, 2008 10:50 am
by MSV
We have updated to V6.00.692 and now have logs of the email problem. (I have changed the names to protect the innocent.)

cheers, Paul

[2008/09/26 01:00:01] ------------------------------------------------------------
[2008/09/26 01:00:01] STATUS-1:> Start running task 3: Munged- DB1 backup.
[2008/09/26 01:00:01] STATUS-1:> Task Settings: Scheme:3|Direct:1|IncFilter:|ExclFilter:|Netshare:0|IncSubdir|IgnoreCase|Repeat:1:2
[2008/09/26 01:00:01] STATUS-1:> Connecting to 10.munged Port 21 (try #1) ...
[2008/09/26 01:00:01] STATUS-1:> Socket connected (IP = 10.99.20.10), waiting for server response ...
[2008/09/26 01:00:01] 220 Microsoft FTP Service
[2008/09/26 01:00:01] COMMAND-1:> USER munged
[2008/09/26 01:00:01] 331 Password required for munged.
[2008/09/26 01:00:01] COMMAND-1:> PASS (not shown)
[2008/09/26 01:00:01] 530 User munged cannot log in.
[2008/09/26 01:00:01] COMMAND-1:> EHLO msvbh04
[2008/09/26 01:00:01] 220 msvbh04.munged Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready at Fri, 26 Sep 2008 01:00:02 +0100
[2008/09/26 01:00:01] STATUS-1:> Error sending notification Email. ‚|Üùµhøµ
[2008/09/26 01:00:01] COMMAND-1:> QUIT
[2008/09/26 01:00:01] 250-msvbh04.munged Hello [10.munged]
[2008/09/26 01:00:01] 250-TURN
[2008/09/26 01:00:01] 250-SIZE
[2008/09/26 01:00:01] 250-ETRN
[2008/09/26 01:00:01] 250-PIPELINING
[2008/09/26 01:00:01] 250-DSN
[2008/09/26 01:00:01] 250-ENHANCEDSTATUSCODES
[2008/09/26 01:00:01] 250-8bitmime
[2008/09/26 01:00:01] 250-BINARYMIME
[2008/09/26 01:00:01] 250-CHUNKING
[2008/09/26 01:00:01] 250-VRFY
[2008/09/26 01:00:01] 250-X-EXPS GSSAPI NTLM LOGIN
[2008/09/26 01:00:01] 250-X-EXPS=LOGIN
[2008/09/26 01:00:01] 250-AUTH GSSAPI NTLM LOGIN
[2008/09/26 01:00:01] 250-AUTH=LOGIN
[2008/09/26 01:00:01] 250-X-LINK2STATE
[2008/09/26 01:00:01] 250-XEXCH50
[2008/09/26 01:00:01] 250 OK
[2008/09/26 01:00:01] STATUS-1:> Disconnected: 10.munged- Fri 01:00:01 26/09/2008

PostPosted: Fri Oct 03, 2008 10:05 pm
by admin
Hi,

Noted. The fix will come out within a couple days.

Thanks.
Leon