Run Program / Before Task not Firing

Everything about TurboFTP Sync Service.

Moderators: idler, Saturn

Run Program / Before Task not Firing

Postby atompkins » Thu Feb 17, 2011 4:31 pm

We have just upgraded to 6.30.842 so that we could begin utilizing the Sync Service.
Tasks that where we specified to Run a Program -> Before task, are not firing off the specified program.
I have also noticed that these same tasks do not Delete After Upload.

I have recreated the task in question and the specified program still is not fired.

I have checked the Run as NT service within the Task Scheduler.

Any suggestions would be appreciated.
atompkins
 
Posts: 5
Joined: Thu Feb 17, 2011 4:22 pm

Re: Run Program / Before Task not Firing

Postby atompkins » Thu Feb 17, 2011 6:17 pm

A correction to my previous post.
It appears the task IS in fact firing the specified program, however, an error is being raised.
I found the following statement in the Task Log.

STATUS-0:> Execute program C:\Tasks\PageSuite\transfer.bat.
[2011/02/17 12:22:28] ERROR-0:> Error executing external program. (#0 The operation completed successfully.)

This failure did not occur before we upgraded to TurboFTP with Sync Service.
atompkins
 
Posts: 5
Joined: Thu Feb 17, 2011 4:22 pm

Re: Run Program / Before Task not Firing

Postby admin » Sat Feb 19, 2011 5:29 pm

Did the external program execute successfully?

Leon
admin
Support Staff
 
Posts: 266
Joined: Mon Jul 11, 2005 1:24 am

Re: Run Program / Before Task not Firing

Postby admin » Sat Feb 19, 2011 6:58 pm

Try enabling 'wait until program terminates'.
admin
Support Staff
 
Posts: 266
Joined: Mon Jul 11, 2005 1:24 am

Re: Run Program / Before Task not Firing

Postby atompkins » Tue Mar 29, 2011 7:41 pm

I have enabled Wait until program terminates but the batch file is still not executed.
atompkins
 
Posts: 5
Joined: Thu Feb 17, 2011 4:22 pm

Re: Run Program / Before Task not Firing

Postby atompkins » Tue Mar 29, 2011 8:17 pm

Below is a log entry created when I select Run Now for the task in question.
I have highlighted the lines that say the external program, transfer.bat, has been run, however, all other signs prove that it has not.
The external program copies PDF files between folders, updating a LOG.TXT file with the PDF filename and a date time stamp.
Once the PDF files are copied, the task will upload them to the desired FTP site.
However, after the task is run, none of the PDF files have been moved nor has the LOG.txt file been updated. In fact, the modified date of the LOG.TXT file is unchanged so I know it is not being updated. And the task goes on as if everything is fine because the local folder it is using, is empty.
Not sure what is going on but my inclination is to believe it is some type of permission issue.
I have verified that the SYSTEM account has full access to the external program.
Plus, I have tried restarting the Sync Service using the administrator account but this also failed.

[2011/03/29 15:58:21] ------------------------------------------------------------
[2011/03/29 15:58:21] STATUS-2:> Start running task 1: Page Suite.
[2011/03/29 15:58:21] STATUS-2:> Task Settings: Scheme:2|Direct:0|IncFilter:*.pdf|ExclFilter:|IncDirFilter:|ExclDirFilter:|Netshare:0|IgnoreCase|Repeat:1:2
[2011/03/29 15:58:21] STATUS-2:> Execute program C:\Tasks\PageSuite\transfer.bat.
[2011/03/29 15:58:21] STATUS-2:> Succeed in running external program.

[2011/03/29 15:58:21] STATUS-2:> Connecting to PSW2.PAGESUITE.CO.UK Port 21 (try #1) ...
[2011/03/29 15:58:21] STATUS-2:> Socket connected (IP = 92.52.72.168), waiting for server response ...
[2011/03/29 15:58:21] 220 Microsoft FTP Service
[2011/03/29 15:58:21] COMMAND-2:> USER elkhart
[2011/03/29 15:58:22] 331 Password required for elkhart.
[2011/03/29 15:58:22] COMMAND-2:> PASS (not shown)
[2011/03/29 15:58:22] 230 User elkhart logged in.
[2011/03/29 15:58:22] COMMAND-2:> SYST
[2011/03/29 15:58:22] 215 Windows_NT
[2011/03/29 15:58:22] COMMAND-2:> FEAT
[2011/03/29 15:58:22] 211-FEAT
[2011/03/29 15:58:22] SIZE
[2011/03/29 15:58:22] MDTM
[2011/03/29 15:58:22] 211 END
[2011/03/29 15:58:22] COMMAND-2:> REST 100
[2011/03/29 15:58:22] 350 Restarting at 100.
[2011/03/29 15:58:22] STATUS-2:> This site can resume broken downloads.
[2011/03/29 15:58:22] COMMAND-2:> REST 0
[2011/03/29 15:58:22] 350 Restarting at 0.
[2011/03/29 15:58:22] COMMAND-2:> CWD /elkhart/The Elkhart Truth
[2011/03/29 15:58:22] 250 CWD command successful.
[2011/03/29 15:58:22] COMMAND-2:> pwd
[2011/03/29 15:58:23] 257 "/elkhart/The Elkhart Truth" is current directory.
[2011/03/29 15:58:23] COMMAND-2:> TYPE A
[2011/03/29 15:58:23] STATUS-2:> Data connection opened.
[2011/03/29 15:58:23] 200 Type set to A.
[2011/03/29 15:58:23] COMMAND-2:> PASV
[2011/03/29 15:58:23] 227 Entering Passive Mode (92,52,72,168,213,91).
[2011/03/29 15:58:23] COMMAND-2:> LIST
[2011/03/29 15:58:23] 125 Data connection already open; Transfer starting.
[2011/03/29 15:58:24] STATUS-2:> 39,934 bytes received in 00:00:00 (51.997 Kbytes/sec)
[2011/03/29 15:58:24] 226 Transfer complete.
[2011/03/29 15:58:24] STATUS-2:> Start synchronizing directories.
[2011/03/29 15:58:24] STATUS-2:> No action performed.
[2011/03/29 15:58:24] STATUS-2:> Disconnected: PSW2.PAGESUITE.CO.UK - Tue 3:58:24 PM 3/29/2011
atompkins
 
Posts: 5
Joined: Thu Feb 17, 2011 4:22 pm

Re: Run Program / Before Task not Firing

Postby atompkins » Tue Mar 29, 2011 8:24 pm

Another note, if I manually run the transfer.bat program, by double clicking it, it completes everything just fine. PDF files are copied and the LOG.TXT file is updated.
atompkins
 
Posts: 5
Joined: Thu Feb 17, 2011 4:22 pm

Re: Run Program / Before Task not Firing

Postby admin » Thu Mar 31, 2011 3:51 am

Another note, if I manually run the transfer.bat program, by double clicking it, it completes everything just fine. PDF files are copied and the LOG.TXT file is updated.


Does your external program path contain white space and if so did you double quote it?

Leon
admin
Support Staff
 
Posts: 266
Joined: Mon Jul 11, 2005 1:24 am

Re: Run Program / Before Task not Firing

Postby sillymilly » Sat Feb 07, 2015 12:22 pm

external program copies PDF files between folders, updating a LOG.TXT file with the PDF filename and a date time stamp.
Once the PDF files are copied, the task will upload them to the desired FTP site.
However, after the task is run, none of the PDF files have been moved nor has the LOG.txt file been updated. In fact, the modified date of the LOG.TXT file is unchanged so I know it is not being updated. And the task goes on as if everything is fine because the local folder it is using, is empty.
sillymilly
 
Posts: 1
Joined: Sat Feb 07, 2015 12:20 pm


Return to TurboFTP Sync Service

Who is online

Users browsing this forum: No registered users and 2 guests

cron