Sync Service randomly fails

Everything about TurboFTP Sync Service.

Moderators: idler, Saturn

Sync Service randomly fails

Postby mawser » Wed Jan 16, 2008 11:18 pm

Hi,

We're currently using the sync service to sync our local folder with a remote ftp folder. The scheduler has the service running constantly throughout the day and most times it runs beautifully.

Occasionally, however the service will stop doing its job and essentially fall over. Stopping and starting the service doesn't seem to fix this nor does restarting TurboFTP, the only solution is to open the scheduler and disable and re enable the jobs.

This running on a Windows 2003 system where folks may log in throughout the day and use TurboFTP but never change the scheduler.

What might be causing it to fail.

We are running it as an NT Service
mawser
 
Posts: 5
Joined: Wed Jan 16, 2008 11:11 pm

Postby zhaojing » Thu Jan 17, 2008 1:38 am

Hi,
Please sent your task log, in order to find the particular problem.
zhaojing
 
Posts: 3
Joined: Wed Jan 16, 2008 5:36 am

Postby mawser » Thu Jan 17, 2008 3:18 pm

Does TurboFTP archive the logs anywhere? It looks like the sync service creates a daily log called 1.log but that gets written over daily?
mawser
 
Posts: 5
Joined: Wed Jan 16, 2008 11:11 pm

Postby Saturn » Fri Jan 18, 2008 1:30 am

Hi,
You can reproduced the problem.If the ID of Task Scheduler is 1,you should find the 1.log .It will show what's the problem.
Saturn
 
Posts: 14
Joined: Fri Jan 18, 2008 1:19 am

Postby mawser » Wed Jan 23, 2008 7:27 pm

I think I've identified where the problem started but I'm not 100% why the schedule would fail from this

I'll paste two logs. 1.log and 2.log. The scheduler has two tasks in it with the number 2 task being dependent on the number 1 task.

As you can see from the logs the 1st task encountered a problem around 23:34:22. Looks like the transfer timed out. 23:34 was the last time job 2 ran, but it looks like job 1 tried to complete at 23:36 and then nothing until I stopped and started the service

Something else I find odd. I've edited the schedules to run every 30 seconds but they're running every second, I'm not sure why that would be.

This is 1.log
[2008/01/18 23:34:21] ------------------------------------------------------------
[2008/01/18 23:34:21] STATUS-0:> Start running task 1: Name Content Only.
[2008/01/18 23:34:21] STATUS-0:> Task Settings: Scheme:0|Direct:0|IncFilter:*.wmv, *.flv, *.swf, *.mov, *.jpg|ExclFilter:DONT_ERASE.pa_tattoo, *.xml|Netshare:0|Repeat:30:7
[2008/01/18 23:34:21] STATUS-0:> Connecting to <servername> Port 21 (try #1) ...
[2008/01/18 23:34:21] STATUS-0:> Socket connected (IP = ip), waiting for server response ...
[2008/01/18 23:34:21] 220-This is a private FTP server. Unauthorized use prohibited.
[2008/01/18 23:34:21] 220-
[2008/01/18 23:34:21] 220 FTP server ready.
[2008/01/18 23:34:21] COMMAND-0:> USER <username>
[2008/01/18 23:34:21] 331 Password required for <username>.
[2008/01/18 23:34:21] COMMAND-0:> PASS (not shown)
[2008/01/18 23:34:21] 230 User <username> logged in.
[2008/01/18 23:34:21] COMMAND-0:> SYST
[2008/01/18 23:34:21] 215 UNIX Type: L8
[2008/01/18 23:34:21] COMMAND-0:> FEAT
[2008/01/18 23:34:22] 500 'FEAT': command not understood.
[2008/01/18 23:34:22] COMMAND-0:> REST 100
[2008/01/18 23:34:22] 350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
[2008/01/18 23:34:22] STATUS-0:> This site can resume broken downloads.
[2008/01/18 23:34:22] COMMAND-0:> REST 0
[2008/01/18 23:34:22] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[2008/01/18 23:34:22] COMMAND-0:> CWD <dir path>
[2008/01/18 23:34:22] 250 CWD command successful.
[2008/01/18 23:34:22] COMMAND-0:> pwd
[2008/01/18 23:34:22] 257 "<dir path>" is current directory.
[2008/01/18 23:34:22] COMMAND-0:> TYPE A
[2008/01/18 23:34:22] STATUS-0:> Data connection opened.
[2008/01/18 23:34:22] 200 Type set to A.
[2008/01/18 23:34:22] COMMAND-0:> PASV
[2008/01/18 23:36:22] STATUS-0:> Aborting...
[2008/01/18 23:36:22] STATUS-0:> Disconnected: <servername2> - Fri 11:36:22 PM 1/18/2008
[2008/01/18 23:36:22] STATUS-0:> Transfer timed out (120 sec). Trying to re-connect...
[2008/01/18 23:36:22] STATUS-0:> Connecting to <servername2> Port 21 (try #1) ...
[2008/01/18 23:36:22] STATUS-0:> Socket connected (IP = ip), waiting for server response ...
[2008/01/18 23:36:23] 220-This is a private FTP server. Unauthorized use prohibited.
[2008/01/18 23:36:23] 220-
[2008/01/18 23:36:23] 220 FTP server ready.
[2008/01/18 23:36:23] COMMAND-0:> USER <username>
[2008/01/18 23:36:23] 331 Password required for <username>.
[2008/01/18 23:36:23] COMMAND-0:> PASS (not shown)
[2008/01/18 23:36:23] 230 User <username> logged in.
[2008/01/18 23:36:23] COMMAND-0:> CWD <dir path>
[2008/01/18 23:36:23] 250 CWD command successful.
[2008/01/18 23:36:23] COMMAND-0:> pwd
[2008/01/18 23:36:23] 257 "<dir path>" is current directory.
[2008/01/18 23:36:23] COMMAND-0:> TYPE A
[2008/01/18 23:36:23] STATUS-0:> Data connection opened.
[2008/01/18 23:36:23] 200 Type set to A.
[2008/01/18 23:36:23] COMMAND-0:> PASV
[2008/01/18 23:36:23] 227 Entering Passive Mo(ip)
[2008/01/18 23:36:23] COMMAND-0:> LIST
[2008/01/18 23:36:23] 150 Opening ASCII mode data connection for /bin/ls.
[2008/01/18 23:36:24] STATUS-0:> 426 bytes received in 00:00:00 (0.683 Kbytes/sec)
[2008/01/18 23:36:24] 226 Transfer complete.
[2008/01/18 23:36:24] STATUS-0:> Resume remote directory scanning.
[2008/01/18 23:36:24] COMMAND-0:> CWD <dir path>
[2008/01/18 23:36:24] 250 CWD command successful.
[2008/01/18 23:36:24] COMMAND-0:> pwd
[2008/01/18 23:36:24] 257 "<dir path>" is current directory.
[2008/01/18 23:36:24] COMMAND-0:> TYPE A
[2008/01/18 23:36:24] STATUS-0:> Data connection opened.
[2008/01/18 23:36:24] 200 Type set to A.
[2008/01/18 23:36:24] COMMAND-0:> PASV
[2008/01/23 09:59:53] STATUS-0:> FTP thread #0, Task #1, (SystemId 324, SFTP 0) terminated (code 0).
[2008/01/23 09:59:56] ------------------------------------------------------------
[2008/01/23 09:59:56] STATUS-0:> Start running task 1: Name Content Only.
[2008/01/23 09:59:56] STATUS-0:> Task Settings: Scheme:0|Direct:0|IncFilter:*.wmv, *.flv, *.swf, *.mov, *.jpg|ExclFilter:DONT_ERASE.pa_tattoo, *.xml|Netshare:0|Repeat:30:7
[2008/01/23 09:59:56] STATUS-0:> Connecting to servername Port 21 (try #1) ...
[2008/01/23 09:59:56] STATUS-0:> Socket connected (IP = ip), waiting for server response ...
[2008/01/23 09:59:57] 220-This is a private FTP server. Unauthorized use prohibited.

Log 2
2008/01/18 23:34:21] ------------------------------------------------------------
[2008/01/18 23:34:21] STATUS-1:> Start running task 2: Name Metadata Only.
[2008/01/18 23:34:21] STATUS-1:> Task Settings: Scheme:0|Direct:0|IncFilter:*.xml|ExclFilter:DONT_ERASE.pa_tattoo, *.wmv, *.flv, *.swf, *.mov, *.jpg|Netshare:0|Repeat:30:7
[2008/01/18 23:34:21] STATUS-1:> Connecting to <servername> Port 21 (try #1) ...
[2008/01/18 23:34:21] STATUS-1:> Socket connected (IP = ip), waiting for server response ...
[2008/01/18 23:34:21] 220-This is a private FTP server. Unauthorized use prohibited.
[2008/01/18 23:34:21] 220-
[2008/01/18 23:34:21] 220 FTP server ready.
[2008/01/18 23:34:21] COMMAND-1:> USER <username>
[2008/01/18 23:34:21] 331 Password required for <username>.
[2008/01/18 23:34:21] COMMAND-1:> PASS (not shown)
[2008/01/18 23:34:21] 230 User <username> logged in.
[2008/01/18 23:34:21] COMMAND-1:> SYST
[2008/01/18 23:34:21] 215 UNIX Type: L8
[2008/01/18 23:34:21] COMMAND-1:> FEAT
[2008/01/18 23:34:21] 500 'FEAT': command not understood.
[2008/01/18 23:34:21] COMMAND-1:> REST 100
[2008/01/18 23:34:21] 350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
[2008/01/18 23:34:21] STATUS-1:> This site can resume broken downloads.
[2008/01/18 23:34:21] COMMAND-1:> REST 0
[2008/01/18 23:34:21] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[2008/01/18 23:34:21] COMMAND-1:> CWD <dir path>
[2008/01/18 23:34:21] 250 CWD command successful.
[2008/01/18 23:34:21] COMMAND-1:> pwd
[2008/01/18 23:34:21] 257 "<dir path>" is current directory.
[2008/01/18 23:34:21] COMMAND-1:> TYPE A
[2008/01/18 23:34:21] STATUS-1:> Data connection opened.
[2008/01/18 23:34:21] 200 Type set to A.
[2008/01/18 23:34:21] COMMAND-1:> PASV
[2008/01/18 23:34:21] 227 Entering Passive Mo(ip)
[2008/01/18 23:34:21] COMMAND-1:> LIST
[2008/01/18 23:34:21] 150 Opening ASCII mode data connection for /bin/ls.
[2008/01/18 23:34:22] STATUS-1:> 426 bytes received in 00:00:00 (0.683 Kbytes/sec)
[2008/01/18 23:34:22] 226 Transfer complete.
[2008/01/18 23:34:22] STATUS-1:> Start synchronizing directories.
[2008/01/18 23:34:22] STATUS-1:> No action performed.
[2008/01/18 23:34:22] STATUS-1:> Disconnected: <servername> - Fri 11:34:22 PM 1/18/2008
[2008/01/23 09:59:53] STATUS-1:> FTP thread #1, Task #2, (SystemId 2604, SFTP 0) terminated (code 0).
[2008/01/23 10:02:26] ------------------------------------------------------------
[2008/01/23 10:02:26] STATUS-1:> Start running task 2: Name Metadata Only.
[2008/01/23 10:02:26] STATUS-1:> Task Settings: Scheme:0|Direct:0|IncFilter:*.xml|ExclFilter:DONT_ERASE.pa_tattoo, *.wmv, *.flv, *.swf, *.mov, *.jpg|Netshare:0|Repeat:30:7
[2008/01/23 10:02:26] STATUS-1:> Connecting to <servername> Port 21 (try #1) ...
[2008/01/23 10:02:26] STATUS-1:> Socket connected (IP = ip), waiting for server response ...
[2008/01/23 10:02:26] 220-This is a private FTP server. Unauthorized use prohibited.


Any help is appreciated.
mawser
 
Posts: 5
Joined: Wed Jan 16, 2008 11:11 pm

Postby zhaojing » Thu Jan 24, 2008 9:36 am

Your question has been forwarded to the 2nd level technical support staff who will be handling it soon.
zhaojing
 
Posts: 3
Joined: Wed Jan 16, 2008 5:36 am

Postby zhaojing » Fri Jan 25, 2008 3:53 am

what is your using version and build number.
zhaojing
 
Posts: 3
Joined: Wed Jan 16, 2008 5:36 am

Postby mawser » Fri Feb 01, 2008 9:25 pm

5.60 Build 620
mawser
 
Posts: 5
Joined: Wed Jan 16, 2008 11:11 pm

Postby admin » Mon Feb 04, 2008 6:48 pm

It seems that your internet link to the server is very slow that might be causing the stall of login process. You should however look at the [Options | Transfer timeout] which specify TurboFTP and Sync Service after how long it should drop the dead connection and reconnect again.
admin
Support Staff
 
Posts: 267
Joined: Mon Jul 11, 2005 1:24 am


Return to TurboFTP Sync Service

Who is online

Users browsing this forum: No registered users and 1 guest

cron